preload button hover image:
HomeSearchRankingsStatisticsAboutContact
Current Time: Oct 16, 2019, 12:50:29 pm
 Mount&Blade Repository
      
Registration is not required to download. However, it will allow you to vote, comment, and request upload access. Forgot your password?
User Name Group Member Since File Listings Comments
Idus Regular User Apr 06, 2007, 07:09:20 pm 0 1
Comments
IP: logged
 Re: The Last Days v2.2.1  » posted under The Last Days v2.4 on Apr 06, 2007, 07:35:31 pm
No the mod doesn't work unless you have version .751, and the mod kind of bridges the gap itself between .751 and .808 so its worth it to get .751 if you don't already have it, but if a newer version of this mod, which just so happened to be made for .808 was made available it would be greatly appreciated, because it's an awesome mod.
HomeSearchRankingsStatisticsAboutContact

Hosted by Hypernia.
Website © 2019 FenriSoft. The core site script is PHCDownload (© 2005-2019).