preload button hover image:
HomeSearchRankingsStatisticsAboutContact
Current Time: May 24, 2018, 10:14:19 pm
 Mount&Blade Repository » Mods » Age of Blackpowder - Realm of Revolution
      
Registration is not required to download. However, it will allow you to vote, comment, and request upload access. Forgot your password?
View this file on the M&B NexusFile Listing: Age of Blackpowder - Realm of Revolution
Last Updated: Mar 27, 2009, 04:43:17 pm
First Created: Mar 27, 2009, 03:35:12 pm
File version: 0.8
For M&B version: 1.010/1.011
Downloads: 43,726 Size: 21.57 MB
Views: 47,627 Type: RAR
Rating (4 votes): 3.5 / 5.0
Description
This is a mod based in the musket era of time. And I hope you enjoy playing it as much as I enjoyed making it.


Factions: United Kingdom of Great Britain and Ireland
Republic of France
United States of America
Kingdom of Svea
Empire of Austria

Credits: I would like to thank the devolepers in The Eagle and the Radiant cross for my dragoon helmet
I would like to thank the devoleper in The Revolution mod to give me a work base
I would like to thank Dain Ironfoot for the 18th century uniforms
I would like to thank RR_Raptor65 for the musket from OSP Weapons
I would like to thank The Pope for the new sabre from OSP Weapons
I would like to thank Captain Lust for the infantry hats he made
I would like to thank MAXHARDMAN for hes new Animations


Features
  • Features: Firearms (does not affect the game system to much, the melee is still a important part in the game


  • Less cavalry, more infantry


  • More damage, less armour


  • Bloodier battles


  • Kings is historical characters


  • New Animations
Commands
More From This Author
Comments (Page 2 of 2)
IP: logged
 Age of Blackpowder - Realm of Revol (v 0.8)  » posted by bernardo03301945 on Feb 22, 2012, 06:56:07 pm
hey guys i really want to play this mod but my version is 1.143 and i cant download 1.011
can u help me?
IP: logged
 Age of Blackpowder - Realm of Revol (v 0.8)  » posted by WallNUTMAAN on Jul 31, 2013, 10:06:06 pm
You have MnB Warband and it version is 1.53 now :-| Anyway u need Mount and Blade not warband to run this mod..
Showing comments 21 to 22 of 22 Showing Page 2 of 2  <  1  2 
HomeSearchRankingsStatisticsAboutContact

Hosted by Hypernia.
Website © 2018 FenriSoft. The core site script is PHCDownload (© 2005-2018).